re = /\bInvoked at: \K[^#]*\d/m
str = '### Invoked at: Wed Dec 7 22:24:35 2022 ###'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end