const regex = /\d{4}\-(?:0?[1-9]|1[0-2])\-(?:0?[1-9]|[12]\d|3[01])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}\\-(?:0?[1-9]|1[0-2])\\-(?:0?[1-9]|[12]\\d|3[01])', 'g')
const str = `2020-05-01
2020-5-3
2020-6-30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}