use strict;
my $str = '2020-05-01
2020-5-3
2020-6-30';
my $regex = qr/\d{4}\-(?:0?[1-9]|1[0-2])\-(?:0?[1-9]|[12]\d|3[01])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}