using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A\d{7}(?!\d)";
string input = @"A1902022 N18-2181 A1234567 1-22-2001 A928882190";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}