$re = '/A\d{7}(?!\d)/m';
$str = 'A1902022 N18-2181 A1234567 1-22-2001 A928882190';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);