import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}) : (V04\\.10\\w+|\\w+ +)(?:\\w+ (\\d,\\d{3}) - )*\\w+ \\d+,\\d{3}";
final String string = "2018-12-18 00:00:00 : TEXT0 TEXT1 0,123 - TEXT2 1,123 - TEXT3 2,123 - TEXT4 3,123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}