const regex = /(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}) : (V04\.10\w+|\w+ +)(?:\w+ (\d,\d{3}) - )*\w+ \d+,\d{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}) : (V04\\.10\\w+|\\w+ +)(?:\\w+ (\\d,\\d{3}) - )*\\w+ \\d+,\\d{3}', 'gm')
const str = `2018-12-18 00:00:00 : TEXT0 TEXT1 0,123 - TEXT2 1,123 - TEXT3 2,123 - TEXT4 3,123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}