import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z].{0,0}$";
final String string = "a\n"
+ "abc\n"
+ "abcd\n"
+ "abcde\n"
+ "a1\n"
+ "a12\n"
+ "a123\n"
+ "a1234\n"
+ "aa1\n"
+ "aa12\n"
+ "aa123\n"
+ "aa1234\n"
+ "a1\n"
+ "a1a\n"
+ "a1a1\n"
+ "a1a1a\n"
+ "a-\n"
+ "a-1\n"
+ "a-1a\n"
+ "a-1-\n"
+ "a-1a-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}