import re
regex = re.compile(r"^[a-zA-Z].{0,0}$", flags=re.MULTILINE)
test_str = ("a\n"
"abc\n"
"abcd\n"
"abcde\n"
"a1\n"
"a12\n"
"a123\n"
"a1234\n"
"aa1\n"
"aa12\n"
"aa123\n"
"aa1234\n"
"a1\n"
"a1a\n"
"a1a1\n"
"a1a1a\n"
"a-\n"
"a-1\n"
"a-1a\n"
"a-1-\n"
"a-1a-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")