import re
regex = re.compile(r"(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$", flags=re.MULTILINE)
test_str = ("edgedb://e_db:pass@host:5656/dbname?tls_security=insecure\n"
"edgedb://e_db:pass@host:5656/dbname\n"
"edgedb://e_db:pass@host:5656/\n"
"edgedb://e_db:pass@host:5656")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")