$re = '/@(?<domain>[^\>]+)/m';
$str = 'Return-Path:<someName@someDomain.com>
Return-Path:<someName@someDomain.com.blah>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);