package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^event/([a-zA-Z0-9-]+)([/]*)`)
var str = `event/12345-12345-12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}