$re = '~^event/([a-zA-Z0-9-]+)([/]*)~';
$str = 'event/12345-12345-12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);