$re = '/^[^{]*(?=({.*?(?1)?.*?})*[^{]*\^).+$/m';
$str = '[[{{6^-2}}x{{6^3}}^{{6^-2}}]]
[[6^6]]
[[{{6^-2}}x{{6^3}}|{{6^-2}}]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);