re = /^[^{]*(?=({.*?(?1)?.*?})*[^{]*\^).+$/m
str = '[[{{6^-2}}x{{6^3}}^{{6^-2}}]]
[[6^6]]
[[{{6^-2}}x{{6^3}}|{{6^-2}}]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end