package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\p{L}+\s\d+\|)+$`)
var str = `Peter 50|alex|
Peter 50|Alex 20|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}