$re = '`^(?:\p{L}+\s\d+\|)+$`m';
$str = 'Peter 50|alex|
Peter 50|Alex 20|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);