package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][0-9]{7}`)
var str = `A1234567
1234567
C1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}