using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(stiffness=(\d))";
string input = @"stiffness=1, delta=3, stiffness=4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}