$re = '/(stiffness=(\d))/';
$str = 'stiffness=1, delta=3, stiffness=4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);