$re = '/\bjack(?:[ &-]+|[ -]?(?:and|n)[ -]?)?jill\b/m';
$str = 'jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackjill | jack jill | jack-jill | jack&jill | jack & jill | jack-&-jill | jack and jill | jackandjill | jack-and-jill | jack n jill';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);