re = /\bjack(?:[ &-]+|[ -]?(?:and|n)[ -]?)?jill\b/m
str = 'jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackjill | jack jill | jack-jill | jack&jill | jack & jill | jack-&-jill | jack and jill | jackandjill | jack-and-jill | jack n jill'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end