$re = '/^((?!\bdefine\b).)*$/m';
$str = 'Hello define
This word is defined here.
define is not allowed.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);