re = /^((?!\bdefine\b).)*$/m
str = 'Hello define
This word is defined here.
define is not allowed.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end