$re = '/[A-Z][a-z]+(\s|,)[A-Z][a-z]{1,19}/';
$str = 'Sunil Kumar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);