using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"bash-1\.\(hello\):.\.0";
string input = @"bash-1.(hello):1.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}