package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)bash-1\.\(hello\):.\.0`)
var str = `bash-1.(hello):1.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}