package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)https?:\/\/\S+?\/(\S+?\/)`)
var str = `http://autoitscript.com/blabla1/
http://autoitscript.com/blabla2/blabla/
http://autoitscript.com/bla-bla-bla3/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}