re = /https?:\/\/\S+?\/(\S+?\/)/im
str = 'http://autoitscript.com/blabla1/
http://autoitscript.com/blabla2/blabla/
http://autoitscript.com/bla-bla-bla3/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end