#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(a)+$"
Local $sString = "xaxxaaaaaa" & @CRLF & _
"xxxxxxaaaaaaaaaaaaaaa" & @CRLF & _
"xxa" & @CRLF & _
"xaa" & @CRLF & _
"xxxxaaaa" & @CRLF & _
"xaxaxxxaaaaaa"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)