$re = '/(a)+$/m';
$str = 'xaxxaaaaaa
xxxxxxaaaaaaaaaaaaaaa
xxa
xaa
xxxxaaaa
xaxaxxxaaaaaa';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;