using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([^{}]+)}";
string input = @"Hello {name}, Hope you are doing well {when}
Hello {name}, Hope you are having a great day
Hello {name}, Nice to meet you";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}