re = /{([^{}]+)}/m
str = 'Hello {name}, Hope you are doing well {when}
Hello {name}, Hope you are having a great day
Hello {name}, Nice to meet you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end