#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:2(?:5[0-5]|[0-4]\d)|1?\d?\d)\.){3}(?:(?:2(?:5[0-5]|[0-4]\d)|1?\d\d|[1-9]))"
Local $sString = "242.139.169.187" & @CRLF & _
"47.230.71.0" & @CRLF & _
"60.243.33.90" & @CRLF & _
"175.96.7.92" & @CRLF & _
"248.13.153.19" & @CRLF & _
"123.96.119.12" & @CRLF & _
"231.77.2.244" & @CRLF & _
"200.153.166.169" & @CRLF & _
"43.239.252.3" & @CRLF & _
"242.125.190.68" & @CRLF & _
"43.17.125.176" & @CRLF & _
"129.95.213.252" & @CRLF & _
"168.30.159.188" & @CRLF & _
"184.191.244.121" & @CRLF & _
"179.206.47.159"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")