package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:2(?:5[0-5]|[0-4]\d)|1?\d?\d)\.){3}(?:(?:2(?:5[0-5]|[0-4]\d)|1?\d\d|[1-9]))`)
var str = `242.139.169.187
47.230.71.0
60.243.33.90
175.96.7.92
248.13.153.19
123.96.119.12
231.77.2.244
200.153.166.169
43.239.252.3
242.125.190.68
43.17.125.176
129.95.213.252
168.30.159.188
184.191.244.121
179.206.47.159`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}