$re = '/(\w{1,2})(\1{1})/m';
$str = 'aaa ab oooh baby wanna cyber?
abc you done fucked up AARON
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);