re = /(\w{1,2})(\1{1})/m
str = 'aaa ab oooh baby wanna cyber?
abc you done fucked up AARON
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end