import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+?\\s\\d{1,2},\\s(\\d{4})";
final String string = "+-------------------------+\n"
+ "|Activity_date |\n"
+ "+-------------------------+\n"
+ "|Jul 20, 2015, 1:06:57 PM |\n"
+ "|Oct 11, 2015, 10:03:14 PM|\n"
+ "|Dec 8, 2016, 4:28:12 PM |\n"
+ "|Dec 12, 2016, 10:22:44 PM|\n"
+ "|Dec 25, 2016, 10:37:32 PM|\n"
+ "+-------------------------+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}