# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+?\s\d{1,2},\s(\d{4})"
test_str = ("+-------------------------+\n"
"|Activity_date |\n"
"+-------------------------+\n"
"|Jul 20, 2015, 1:06:57 PM |\n"
"|Oct 11, 2015, 10:03:14 PM|\n"
"|Dec 8, 2016, 4:28:12 PM |\n"
"|Dec 12, 2016, 10:22:44 PM|\n"
"|Dec 25, 2016, 10:37:32 PM|\n"
"+-------------------------+")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.