package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(?:\.\d+)*[\s\S]*?\w+\.`)
var str = ` 1 One without dot. 2. Some Random String. 3.1 With SubItens. 3.2 With Another SubItem. 4. List item. 11.12 More than one digit.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}