re = /\d+(?:\.\d+)*[\s\S]*?\w+\./
str = ' 1 One without dot. 2. Some Random String. 3.1 With SubItens. 3.2 With Another SubItem. 4. List item. 11.12 More than one digit.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end