import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.*?c{11}|(\\d+\\.\\d+\\.\\d+\\.\\d+)";
final String string = "ddddddhhhhhhf jjjjjj 111.222.33.444 dddddd ddddddddddd\n"
+ "ccccccccccc\n"
+ "xxxxxxxxxx xxxxxxxxxj kkkkkk kkkkkk xxxxx111.222.888.444yyyy\n"
+ "xxxxxxxxxx xxxxxxxxxj kkkkkk kkkkkk xxxxx111.555.888.444yyyy\n"
+ "dddddd jjjjjjj 333.222.33.444 111.222.33.444 jjjjjjjjjjjj";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}