import re
regex = re.compile(r"(?s)^.*?c{11}|(\d+\.\d+\.\d+\.\d+)")
test_str = ("ddddddhhhhhhf jjjjjj 111.222.33.444 dddddd ddddddddddd\n"
"ccccccccccc\n"
"xxxxxxxxxx xxxxxxxxxj kkkkkk kkkkkk xxxxx111.222.888.444yyyy\n"
"xxxxxxxxxx xxxxxxxxxj kkkkkk kkkkkk xxxxx111.555.888.444yyyy\n"
"dddddd jjjjjjj 333.222.33.444 111.222.33.444 jjjjjjjjjjjj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")