$re = '/\b\w+(?=\s*[,()])/m';
$str = 'MethodName(int? Property1, string Property2, List<int?> Property3)
MethodName()
MethodName(int? Property1, string Property2, List<int?> Property3, int Property4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);