re = /\b\w+(?=\s*[,()])/m
str = 'MethodName(int? Property1, string Property2, List<int?> Property3)
MethodName()
MethodName(int? Property1, string Property2, List<int?> Property3, int Property4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end