$re = '/^(?!0+(?:\.0+)?)\d*(?:\.\d+)?$/m';
$str = '
0
0.0000
-0
-0.0000
123
123.456
-123
-123.456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);