re = /^(?!0+(?:\.0+)?)\d*(?:\.\d+)?$/m
str = '
0
0.0000
-0
-0.0000
123
123.456
-123
-123.456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end