# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"name=\"(?P<name>\w+)\"\>[\w\<\/\.\>\d:]+documentation\>(?P<desc>.+?)\<\/"
test_str = "<xs:element name=\"ProductDescription\"><xs:annotation><xs:documentation>Provides the description of the product</xs:documentation></xs:annotation><xs:complexType><xs:sequence><xs:element name=\"ProductName\"><xs:annotation><xs:documentation>Provides a name for the product. (see list)</xs:documentation></xs:annotation><xs:simpleType><xs:restriction base=\"xs:token\"><xs:enumeration value=\"Barbie Doll\"/><xs:enumeration value=\"Ken Doll\"/></xs:restriction></xs:simpleType></xs:element><xs:element name=\"ProductSize\"><xs:annotation><xs:documentation>Describes the size of the product. (see list)</xs:documentation></xs:annotation><xs:simpleType><xs:restriction base=\"xs:token\"><xs:enumeration value=\"Small\"/><xs:enumeration value=\"Medium\"/><xs:enumeration value=\"Large\"/><xs:enumeration value=\"Dayum\"/></xs:restriction></xs:simpleType></xs:element></xs:sequence></xs:complexType></xs:element>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.