#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+ \((?:[1-9]|[1234][0-9])\)(?:, )?"
Local $sString = "I can not find a working regular expression to match the strings followed by a number from 1 to 49 in braces, in a list dividing the pairs by comma:" & @CRLF & _
"" & @CRLF & _
"alpha (1), beta (12), gamma (37), delta (49), epsilon (55), zeta (64)" & @CRLF & _
"" & @CRLF & _
"but also in random order and amount of pairs like" & @CRLF & _
"" & @CRLF & _
"zeta (64), alpha (1), gamma (37), beta (12), delta (49), epsilon (55), eta (48), theta (26)" & @CRLF & _
"" & @CRLF & _
"and also random numbers like" & @CRLF & _
"" & @CRLF & _
"zeta (11), gamma (71), beta (49), delta (52), epsilon (99), alpha (33)" & @CRLF & _
"" & @CRLF & _
"I'm looking for an endresult showing only the pairs with a number lower as 49 like" & @CRLF & _
"" & @CRLF & _
"alpha (1), beta (12), gamma (37), delta (49)" & @CRLF & _
"" & @CRLF & _
"alpha (1), gamma (37), beta (12), delta (49), eta (48), theta (26)" & @CRLF & _
"" & @CRLF & _
"zeta (11), beta (49), alpha (33)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")