# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+ \((?:[1-9]|[1234][0-9])\)(?:, )?"
test_str = ("I can not find a working regular expression to match the strings followed by a number from 1 to 49 in braces, in a list dividing the pairs by comma:\n\n"
"alpha (1), beta (12), gamma (37), delta (49), epsilon (55), zeta (64)\n\n"
"but also in random order and amount of pairs like\n\n"
"zeta (64), alpha (1), gamma (37), beta (12), delta (49), epsilon (55), eta (48), theta (26)\n\n"
"and also random numbers like\n\n"
"zeta (11), gamma (71), beta (49), delta (52), epsilon (99), alpha (33)\n\n"
"I'm looking for an endresult showing only the pairs with a number lower as 49 like\n\n"
"alpha (1), beta (12), gamma (37), delta (49)\n\n"
"alpha (1), gamma (37), beta (12), delta (49), eta (48), theta (26)\n\n"
"zeta (11), beta (49), alpha (33)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.